Des caractères accentués en console mais pas sous X

La question :

Bonsoir tout le monde,

je vous écris parce que j'ai depuis plusieurs semaines un problème
agaçant. En effet lorsque que j'utilise GNU/Emacs en mode console mes
accents passent comme une lettre à la poste par contre si je lance Emacs
en mode X (donc sans le paramètre -nw) il m'est impossible d'utiliser les
caractères accentués. À la place de ceux-ci apparaissent des rectangles ...

Lorsque que je suis sous X, j'utilise Gnome et un gnome-terminal. Dans le
gnome-terminal tout se passe bien donc ... Je lance Gnome en ISO-8859-15.

Dans mon fichier ~/.emacs.el j'ai la chose suivante :
(set-terminal-coding-system 'latin-1)
(set-keyboard-coding-system 'latin-1)
(set-language-environment 'latin-1)

J'ai déjà essayé les quelques astuces que j'ai pu trouver sur
google-groups mais sans succès.

Je m'en remet donc à vous

Bonne soirée, et à bientôt j'espère.
--
Nicolas Cavigneaux | GPG KeyID : F0954C41
| http://bounga.ath.cx

Poser votre question sur le forum OS alternatifs

Les 4 réponses :

Nicolas Cavigneaux a écrit :


Bonsoir tout le monde,


Bonsoir,

[...]


il m'est impossible d'utiliser les
caractères accentués.


As-tu regardé

http://www-verimag.imag.fr/~moy/emacs/#accents

?


À la place de ceux-ci apparaissent des rectangles ...


Ca ressemble à un problème de police, c'est à dire que Emacs dit « il
faut afficher un `é' » à ton serveur X, mais que le serveur X en
question n'a pas la police qu'il faut et met un rectangle à la place.

Tu peux regarder le résultat de la commande C-u C-x = avec le curseur
sur un caractère accentué pour vérifier.

Tu devrais essayer

1) De lancer emacs -font "une-fonte-qui-va-bien",
où "une-fonte-qui-va-bien" est choisie avec xfontsel par exemple.

2) D'installer ucs-tables.el, on ne sais jamais

3) De reprendre ta config Emacs à partir de 0. (mv .emacs.el
..emacs.el.bak, et on repart sur de bonnes bases).


Lorsque que je suis sous X, j'utilise Gnome et un gnome-terminal. Dans le
gnome-terminal tout se passe bien donc ... Je lance Gnome en ISO-8859-15.


4) De lancer Gnome en ISO-8859-1

--
Matthieu

Tiens en fait je viens de remarquer quelque chose d'encore plus étrange.
Quand je lance Emacs en mode X mais depuis une console ça fonctionne
parfaitement, mais si je lance Emacs à l'aide d'un lanceur graphique
(icône) les accents ne passent pas ...
--
Nicolas Cavigneaux | GPG KeyID : F0954C41
| http://bounga.ath.cx

Nicolas Cavigneaux a écrit :


Tiens en fait je viens de remarquer quelque chose d'encore plus étrange.
Quand je lance Emacs en mode X mais depuis une console ça fonctionne
parfaitement, mais si je lance Emacs à l'aide d'un lanceur graphique
(icône) les accents ne passent pas ...


Regardes la commande précise utilisée par ton lanceur, il doit y avoir
une option "-font" quelque part. Sinon, joue de la commande "ps u"
pour savoir comment ton Emacs a été appelé.

--
Matthieu

Le Mon, 23 Feb 2004 23:52:06 +0100, Matthieu Moy a écrit :


Ca ressemble à un problème de police, c'est à dire que Emacs dit « il
faut afficher un `é' » à ton serveur X, mais que le serveur X en
question n'a pas la police qu'il faut et met un rectangle à la place.


En plein dans le mille, j'utilisais une police qui n'existe pas en en
ISO-8859-15 c'est donc pour cette raison que j'avais des problèmes .

Merci beaucoup pour votre aide.

Bonne soirée.
--
Nicolas Cavigneaux | GPG KeyID : F0954C41
| http://bounga.ath.cx

Poser votre question sur le forum OS alternatifs

Questions similaires :

conversion de caractères échappés en hexa vers unicode

Le 3 octobre 2013 à 02:14, Sébastien Kirche a tapoté : Une idée m'a été donnée sur StackOverflow pour tenter de retrouver un tel caractère : (decode-coding-string "\x490a4 " 'emacs-mule) Malheureusement elle ne fonctionne pas dans mon cas, l'auteur de l'idée suggère que ce codepoint provenait...

Caractères accentués mal rendus lors de l'import d'une signature

'Lut, Gnus/5.13 (Gnus v5.13) Emacs/24.2 (berkeley-unix) Depuis le passage d'Emacs23 à Emacs24, je rencontre un problème avec les signatures insérées par les posting styles de Gnus. Le code correspondant dans .gnus est le suivant : ;; ;; Signatures ;; (defun signature-function...

Abbrev mode avec des caractères accentués

Salut, Je définis une abréviation avec des caractères accentués dedans (forcément en français). Mais l'abréviation ne se développe pas. Je suis sûr qu'il y a quelque part une expression rationnelle à configurer, mais je ne trouve pas où... Toute aide est la bien venue. Vincent.

comparer une variable avec une chaine de caractères

bonjour à tou(te)s voici le début d'une petite fonction que je tente de mettre au point : (defun lille-simplement-choisir () (interactive "sChoix (Oui/Non) : ") (if ((equal Choix "Oui")) (progn (kill-line nil)) ) ) J'ai une erreur --- comme doivent s'en apercevoir ceux qui savent :) --- au niveau...

Insertion de chaîne de caractères

Bonjour J'utilise la fonction insert pour insérer des caractères dans un texte : (insert "htFF9050070000") et le résultat est : ht7FE44500130000 Qu'est-ce qui se passe? Comment faire pour retrouver mes caractères ? Merci Nicolas