Firefox - Recherche de mot dans la page

La question :

Bonjour

Toujours avec Firefox 12.0, sous Kmint quand je fais Ctrl + F avec le
mot inverseur dans cette page :

http://www.hellopro.fr/COMAP-142984-noprofil-fr-societe.html

l?ascenseur la positionne plus bas, mais il n'y a pas le mot surligné,
Pourtant dans les sources se retouve bien :

http://www.hellopro.fr/images/produit-2/4/3/0/coupleur-inverseur-165-b-nf-m-88-770-ref-0165b00-163034.gif

C'est un problème récurrent et vraiment mal-pratique, c'est normal ça ?
Solution ou pas ?

Merci de vos avis.


--
capfree

Poser votre question sur le forum Logiciels

Les 9 réponses :

Le 23/11/2012 09:32, *capfree* a écrit fort à propos :


Bonjour

Toujours avec Firefox 12.0, sous Kmint quand je fais Ctrl + F avec le
mot inverseur dans cette page :

http://www.hellopro.fr/COMAP-142984-noprofil-fr-societe.html

l?ascenseur la positionne plus bas, mais il n'y a pas le mot surligné,
Pourtant dans les sources se retouve bien :

http://www.hellopro.fr/images/produit-2/4/3/0/coupleur-inverseur-165-b-nf-m-88-770-ref-0165b00-163034.gif

C'est un problème récurrent et vraiment mal-pratique, c'est normal ça ?


Je pense que c'est normal puisque « inverseur » n'est affiché nulle part
dans la page. L'outil de recherche n'est pas censé regarder dans le code
source tant que ce n'est pas celui-ci que tu affiches.

Une autre bizarrerie m'étonne d'avantage : Chaque fois que le pointeur de la
souris a survolé et quitte un lien « Tous les fournisseurs », celui-ci
disparaît. C'est normal ça ?

Le 23/11/2012 10:51, j'ai écrit :


Une autre bizarrerie m'étonne d'avantage : Chaque fois que le pointeur de la
souris a survolé et quitte un lien « Tous les fournisseurs », celui-ci
disparaît. C'est normal ça ?


Euh, pardon, j'ai oublié de préciser que ce phénomène se manifeste avec
Seamonkey 2.13.2 mais pas avec Firefox (10.0.10).

Le 23/11/2012 10:51, geo cherchetout a écrit :


Le 23/11/2012 09:32, *capfree* a écrit fort à propos :


Bonjour

Toujours avec Firefox 12.0, sous Kmint quand je fais Ctrl + F avec le
mot inverseur dans cette page :

http://www.hellopro.fr/COMAP-142984-noprofil-fr-societe.html

l?ascenseur la positionne plus bas, mais il n'y a pas le mot surligné,
Pourtant dans les sources se retouve bien :

http://www.hellopro.fr/images/produit-2/4/3/0/coupleur-inverseur-165-b-nf-m-88-770-ref-0165b00-163034.gif


C'est un problème récurrent et vraiment mal-pratique, c'est normal ça ?


Je pense que c'est normal puisque « inverseur » n'est affiché nulle part
dans la page. L'outil de recherche n'est pas censé regarder dans le code
source tant que ce n'est pas celui-ci que tu affiches.


Ben oui, mais le code source a bien généré la page, mystère des
/htmlistes/
Et si je mets un mot introuvable «abracadabra» par exemple, l'ascenseur
ne bouge pas et la fenêtre de recherche rougit fortement, et là c'est
très bien !



Une autre bizarrerie m'étonne d'avantage : Chaque fois que le pointeur
de la souris a survolé et quitte un lien « Tous les fournisseurs »,
celui-ci disparaît. C'est normal ça ?


J'avais remarqué, encore une astuce de programmeur

--
capfree

Le 23/11/2012 10:51, j'ai écrit trop vite :


Je pense que c'est normal puisque « inverseur » n'est affiché nulle part
dans la page. L'outil de recherche n'est pas censé regarder dans le code
source tant que ce n'est pas celui-ci que tu affiches.


Désolé, j'ai oublié que mon navigateur habituel est Seamonkey et que le
problème signalé concerne Firefox.
En fait, avec Firefox 10.0.10 sous Linux, le mot inverseur est bien trouvé
alors qu'il ne l'est pas avec Seamonkey ! Cela s'explique peut-être par le
fait que le rendu de la page diffère considérablement d'un navigateur à
l'autre :
Seamonkey 2.13.2 s'efforce d'afficher côte à côte sur une même ligne
horizontale les produits de la sélection et, comme ces produits sont trop
nombreux, le seul contenant le mot INVERSEUR (en majuscules) est déporté
hors page et donc invisible :
http://pix.toile-libre.org/upload/original/1353666087.png

En revanche, Firefox répartit tous les produits sur cinq lignes et tous sont
donc bien affichés, illustration et légende :
http://pix.toile-libre.org/upload/original/1353665901.png

Pour conclure, j'ajoute mon grain de sel mais n'apporte aucune réponse à la
question originale.

Le 23/11/2012 10:51, geo cherchetout répondait à capfree :



Toujours avec Firefox 12.0, sous Kmint quand je fais Ctrl + F avec le
mot inverseur dans cette page :

http://www.hellopro.fr/COMAP-142984-noprofil-fr-societe.html

l?ascenseur la positionne plus bas, mais il n'y a pas le mot surligné,
Pourtant dans les sources se retouve bien :

http://www.hellopro.fr/images/produit-2/4/3/0/coupleur-inverseur-165-b-nf-m-88-770-ref-0165b00-163034.gif

C'est un problème récurrent et vraiment mal-pratique, c'est normal ça ?


J'ai la même chose dans SeaMonkey 2.14 et Firefox 17.0 sur Windows. Ça
ne me semble pas normal, même si je n'ai pas cherché de quelle manière
ce mot est caché (display:none ou visibility:hidden ?)


Je pense que c'est normal puisque « inverseur » n'est affiché nulle part
dans la page. L'outil de recherche n'est pas censé regarder dans le code
source tant que ce n'est pas celui-ci que tu affiches.


Eh bien justement, ce qui n'est pas normal, c'est qu'il *trouve* le mot,
alors qu'il n'est pas affiché. Tu peux faire l'expérience en tapant (par
exemple) « /inverser ». Tant que tu n'as écrit que « inverse », la zone
de recherche reste en blanc, mais dès que tu saisis le dernier « r » au
lieu de « u » elle passe en rouge car ce mot-là n'est pas trouvé.

Poser votre question sur le forum Logiciels

Questions similaires :

[Firefox] Recherche dans la page

Le 10/08/2015 13:21, Elephant Man a écrit : Bonjour. Chez moi, dans la colonne de droite, là où sont présentées des applications connexes. De rien. [/color] Même en cliquant dessus je ne peux les voir, sauf en passant par ->affichage ->aucun style Merci -- capfree -

Firefox : conserver certains cookies

Le 25/07/2015 12:36, siger a écrit : Normalement, il faut redémarrer le navigateur pour activer une extension fraîchement installée, mais pas le système. -- Fañch

Firefox et localisation

Sergio a écrit : Lire: Dans la barre d'adresse, saisissez about:config - Saisissez geo.enabled dans le champ « Filtre » - Faites un double-clic sur la préférence geo.enabled[/color] Merci. Je suppose que "false" signifie désactivé, et "true" activé. C'est à "true", je ne l'avais donc pas...

firefox page de personnalisation vide

Le 16/07/2015 09:52, Sergio a écrit : A tester avant, dans le menu '?', le menu 'Informations de dépannage' Il y a une option 'Réparer Firefox' qui fait ca en un seul clic Thierry

[FireFox] Téléchargement vidéo depuis lien http

Bonjour, Le Jeudi, 02/07/2015 22:43, PP a écrit le message : T'as pas Windows ?[/color] j'ai Windows et Linux, et les deux FireFox n'ont pas cette clé[/color] Voir : Ça c'est avec la version Linux.[/color] j'ai la même chose sur la version...