Service Windev pour imprimer directement un Etat

La question :

SVP je crée un service Windev pour imprimer directement un Etat basé sur une requête, le problème est que la requête s?exécute bien mais sans aucune impression. Aidez moi. Merci infiniment.
Je signale qu en mode Déboguer le service fonctionne correctement.

Poser votre question sur le forum Programmation

Les 7 réponses :

un service peut acceder aux imprimantes ????
jamais essayé mais si ton soft fonctionne en mode debug (donc avec unesession windows derriere) et n'a pas le meme comportement lorsqu'il tourneen service ca ne m'etonne pas.

t'as pas plus d'infos ?
c'est le service qui effectue la requete et qui l'envoi à l'imprimante?

Le lundi 16 janvier 2017 16:43:55 UTC, soul...@gmail.com a écrit :


SVP je crée un service Windev pour imprimer directement un Etat basé sur une requête, le problème est que la requête s?exécute bien mais sans aucune impression. Aidez moi. Merci infiniment.
Je signale qu en mode Déboguer le service fonctionne correctement.


Merci beaucoup pour votre intervention.
Voici la procedure executée dans le bloc (appelé en boucle):
PROCEDURE pG_imprime()
HExécuteRequête(REQ_MImprime)
SI HLitPremier(REQ_MImprime) ALORS
TANTQUE HTrouve(REQ_MImprime)
iInitRequêteEtat(ETAT_ticketM,REQ_MImprime.IDcommandes)
iAperçu(iImprimante)
iFenêtreAbandon(Faux)
iImprimeEtat(ETAT_ticketM)
SI HLitRecherchePremier(commandes,IDcommandes,REQ_MImprime.IDcommandes) ALORS
commandes.imprime=0
HModifie(commandes)
FIN
HLitSuivant(REQ_MImprime)
FIN
FIN

Le lundi 16 janvier 2017 20:27:59 UTC, tjfro...@gmail.com a écrit :


un service peut acceder aux imprimantes ????
jamais essayé mais si ton soft fonctionne en mode debug (donc avec une session windows derriere) et n'a pas le meme comportement lorsqu'il tourne en service ca ne m'etonne pas.

t'as pas plus d'infos ?
c'est le service qui effectue la requete et qui l'envoi à l'imprimante ?


Merci beaucoup pour votre intervention.
Oui.
Voici la procedure executée dans le bloc (appelé en boucle):
PROCEDURE pG_imprime()
HExécuteRequête(REQ_MImprime)
SI HLitPremier(REQ_MImprime) ALORS
TANTQUE HTrouve(REQ_MImprime)
iInitRequêteEtat(ETAT_ticketM,REQ_MImprime.IDcommandes)
iAperçu(iImprimante)
iFenêtreAbandon(Faux)
iImprimeEtat(ETAT_ticketM)
SI HLitRecherchePremier(commandes,IDcommandes,REQ_MImprime.IDcommandes) ALORS
commandes.imprime=0
HModifie(commandes)
FIN
HLitSuivant(REQ_MImprime)
FIN
FIN

a couché sur son écran :


SVP je crée un service Windev pour imprimer directement un Etat basé sur une
requête, le problème est que la requête s?exécute bien mais sans aucune
impression. Aidez moi. Merci infiniment. Je signale qu en mode Déboguer le
service fonctionne correctement.


J'ai eu le même problème, confronté à des problèmes de droits vis à vis
du service et de l'impression j'ai abandonné.
Le Service lance maintenant un executable qui lui accède correctement à
l'impression.

Le 16/01/2017 à 23:31, a écrit :


Le lundi 16 janvier 2017 20:27:59 UTC, tjfro...@gmail.com a écrit :


un service peut acceder aux imprimantes ????
jamais essayé mais si ton soft fonctionne en mode debug (donc avec une session windows derriere) et n'a pas le meme comportement lorsqu'il tourne en service ca ne m'etonne pas.

t'as pas plus d'infos ?
c'est le service qui effectue la requete et qui l'envoi à l'imprimante ?


Merci beaucoup pour votre intervention.
Oui.
Voici la procedure executée dans le bloc (appelé en boucle):
PROCEDURE pG_imprime()
HExécuteRequête(REQ_MImprime)
SI HLitPremier(REQ_MImprime) ALORS
TANTQUE HTrouve(REQ_MImprime)
iInitRequêteEtat(ETAT_ticketM,REQ_MImprime.IDcommandes)
iAperçu(iImprimante)
iFenêtreAbandon(Faux)
iImprimeEtat(ETAT_ticketM)
SI HLitRecherchePremier(commandes,IDcommandes,REQ_MImprime.IDcommandes) ALORS
commandes.imprime=0
HModifie(commandes)
FIN
HLitSuivant(REQ_MImprime)
FIN
FIN


ca doit fonctionner si le service tourne avec un utilisateur autre que
system et qui les droits sur l'imprimante en question...

Poser votre question sur le forum Programmation

Questions similaires :

Réplication windev 22

a présenté l'énoncé suivant : Bonjour, 1. Base locale par défaut (HF Classic) MONFICHIER - Description d'une connexion CnxLocale - HOuvreConnexion(CnxLocale) - HChangeRep(MONFICHIER, sRepertoireDonnéesLocales) - éventuellement HPasse(MONFICHIER, xxx) si crypté -...

windev 19 et W10 creator udpdate

titou44 a exposé le 07/08/2017 : je me réponds trouvé des liens dans les forums officiels

windev mobile date du jour champ table

Le 13/06/2017 12:08, Julien Delcourt a écrit : Bonjour Par défaut les champs ne mémorisent pas les sélection., je vous invite dont à le faire vous même : c'est très simple. Créez deux entiers global à votre fenêtre fnLigne, fnLignePrec sont des entiers Affectez ce dernier dans le code de...

récupérer le résultat d'une requête windev

Le 25/04/2017 14:13, a écrit : ok, entre l'aide et google tu aurais du t'en sortir une requête windev est la même chose qu'une requête texte : il faut donc l'exécuter (le serveur va l'exécuter et créer un contexte de fichier sur le résultat)... et parourir le résultat // exécution si pas...

un tuto en écriture pour exécuter les plans en windev

> Bonjour, je voudrais avoir un tuto en écriture pour exécuter les plans en Pour quelle version de Windev ? -- Cordialement, André STASZEWSKI Pour me contacter, cliquez ici :