affichage google map api

La question :

Bonjour,
Je travail actuellement sur l'integration d'une carte google map pour
le site de ma boite
j'ai repris le code de l'ancien site qui intégrait deja l'api, et qui
fonctionnait très bien
le contenu de la page reste inchangée d'ailleur

cette page est en fait une iframe qui irécupère les données d'un
formulaire présent dans la page contenant l'iframe
je construit donc ma requete en interrogeant ma bas de donnée, puis
j'affiche une carte et une liste d'elements
je cache en premier lieu la carte et un bouton permet de switcher
entre la carte et la liste
chacun des elements de la liste crée un marqueur (un point sur la
carte)
ceux-ci s'affichent tous correctement partout
aucun probleme a ce niveau là


mon problème : lorsque je charge la page (sans aucun critère de
restriction dans le formulaire donc), la carte s'affiche correctement
sous IE et mozilla
pas sous chrome (le navigateur de google...), ni netscape, ni safari
ni opera
par contre, dès que je restreint ma recherche a l'aide du formulaire
(ou au moyen de variables de sessions), la carte s'affiche
correctement sous IE
mais plus sous aucun autre
seul le coin haut-gauche de la carte est visible sous les autres
navigateurs

J'ai tester plusieursde solution, je chargais au depart la carte
directement dans le code html (dans le body, a l'aide de balise
script), marchais pas
j'ai donc fais une fonction de chargement, ça a eu le mérite de faire
fonctionner l'affichage sous IE (ce qui n'etais pas le cas au debut)
J'ai inspecter tous le code généré une dizaine de fois car j'ai vu sur
un forum que le probleme venait surement d'une balise non fermer...
nada, aucune erreur la non plus
J'ai desactivé tous mes modules complémentaires, que dal, j'ai vu
plusieurs fois que le probleme pouvait venir de skype... je l'ai pas :
(

et ce n'est pas non plus un probleme de cache, j'ai beau le vider ça
change absolument rien...

je suis perdu là... help !

Poser votre question sur le forum Logiciels

Les 2 réponses :

problème règlé, merci quand meme

a écrit :


problème règlé, merci quand meme


ce newsgroup n'est pas vraiment orienté programmation et espérer avoir
une réponse en moins d'une heure sur un newsgroup (qui est non
commercial, je te le rappelle) relève un peu de l'utopie ou de la chance

Par contre, ta solution pourrait servir à d'autre si tu voulais la
partager (c'est d'ailleurs un des principes des newsgroups: partager)

Poser votre question sur le forum Logiciels

Questions similaires :

Pas moyen de se connecter à google avec firefox

Le 28/05/2017 à 17:08, Jo Engo a écrit : C'est le principal si ça marche ! - Dominique Courriel : dominique point sextant ate orange en France Esto quod es

la parano chez google

Salut, Denis Beauregard a écrit le 07/03/2016 17:08 : Il me semble que Seamonkey n'a pas adopté ce stupide espionnage de google.[/color] Par contre, seamonkey est sur une pente descendante. Il est de moins en moins performant, comme si on enlevait des fonctions quand il y a un problème au...

Navigateur et Secure WebSocket (WebKit versus Google Chrome)

Le 26/02/2014 14:26, Une Bévue a écrit : Bon, j'ajoute que ça marche aussi avec : FirefoxNightly Opera Safari Maxthon seul donc Google Chromea posé problème, c'est mon navigateur par défaut...

La barre noire de Google

>Il y a quelques temps je cherchais à récupérer la barre noire de Google Moi qui cherchais à une époque s'il y avait moyen de la virer, je suis ravie qu'elle ait disparu :)

Pas d'icônes sur les marques pages après réinstallation de firefox et problème avec google.fr.

*Bonjour/Bonsoir/Bonne nuit Delta Ophiuchus*, qui a écrit le 13/10/2013 12:12 : sa présence dépend du cookie "PREF" de google. pour la retrouver il suffit d'appeler un domaine étranger : ; ; ... ou de supprimer ce cookie[/color] La combinaison doit être plus subtile car ça ne fonctionne...